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1 INLEIDING – DIGITAAL VLAANDEREN 
OGC API’s – Open Geospatial Consortium Application Programming Interfaces – worden gepromoot voor 

hun gebruik onder ontwikkelaars met beperkte ervaring met geografische data en diensten. Ook Digitaal 

Vlaanderen is bezig met de implementatie van deze OGC API’s waarbij momenteel alle reeds bestaande 

datasets als WFS, sinds maart 2022 ook beschikbaar zijn als OGC API Features. Waar Web Features Services 

(WFS) eerder enkel data aanboden als GML, kan er via de REST API’s data bevraagd worden in json, geo-

json, jsonld en HTML formaat. Ook de implementatie van OGC API Coverages, OGC API Tiles en OGC API 

Maps staan ingepland voor de toekomst. Meer informatie over het aanbod van OGC API’s door Digitaal 

Vlaanderen vind je hier:  

Wat u zeker moet weten over OGC API’s en waarom Digitaal Vlaanderen ze voortaan aanbiedt. 

In dit document worden de toepassingen van de  OGC API Features van Digitaal Vlaanderen besproken, hoe 

de data bevraging en export werkt, hoe de opmaak kan aangepast worden en wat de verschillen juist zijn 

met de reeds aangeboden WFS.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

https://www.vlaanderen.be/digitaal-vlaanderen/nieuwsberichten/wat-u-zeker-moet-weten-over-ogc-apis-en-waarom-digitaal-vlaanderen-ze-voortaan-aanbiedt
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2 GIDS VOOR OCG API FEATURES VAN DIGITAAL 

VLAANDEREN 

2.1 LANDINGSPAGINA 

 

Door op de Endpoint URL te klikken van een OGC API Feature (zie 3.1.2) kom je op de ‘landingspagina’ 

terecht. Hier vind je links terug naar de:  

• API definitie: Een beschrijving van de service en de verschillende ondersteunde GET capabilities. 

Deze link verwijst je door naar een Swagger UI, een tool die gebruikt wordt om automatisch een 

RESTful API document samen te stellen. Onder Data kan je de verschillende parameters 

terugvinden die gebruikt kunnen worden om de data van een OGC API Feature te filteren zoals de 

limiet van het aantal bevraagde features, het gebruikte coördinaat systeem, etc. Hierbij is het ook 

mogelijk om in de tool zelf een filter tryout te doen door het zelf invullen van parameters en een 

GET request uit te sturen om de gefilterde data te bevragen.  

 

• Collecties: Alle collecties, of lagen, die beschikbaar zijn in de service.  

• Conformiteit: de OGC API-conformiteitsklassen die door deze service worden geïmplementeerd. 

Deze conformiteitsklassen verwijzen naar links die de voorschriften en vereisten van een OGC API 

stellen.   



Gebruik van OGC API’s in ArcGIS Pro 

 

 
 SIGGIS – Intern iv 

3 OGC API FEATURES IN ARCGIS PRO 
De werking van OGC API Features in ArcGIS Pro loopt grotendeels gelijk met die van WFS. Na het toevoegen van 

een OGC API Features laag, is deze beschikbaar als read-only. Dit houdt in dat de attributentabel kan bekeken 

worden, features kunnen opgevraagd worden in de kaart of de opmaak van de laag kan worden aangepast. De 

data of het dataschema kan echter niet bewerkt worden aangezien de laag niet editeerbaar is. Wil je de features 

toch kunnen bewerken, zal je de laag moeten exporteren als kopie. Deze laag zal dan niet meer automatisch 

bijgewerkt worden.  

3.1 HOE EEN CONNECTIE LEGGEN 

1. Zoek de gewenste OGC API Features dataset in de online Catalogus van Digitaal Vlaanderen: 

Datavindplaats - Catalogus. Momenteel zijn er 81 datasets beschikbaar.  

 

2. Na keuze van de dataset, kopieer je de Endpoint URL en ga je naar je project in ArcGIS Pro.  

 

 

 

https://www.vlaanderen.be/datavindplaats/catalogus?order_relevance=asc
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3. Navigeer naar Insert > Connections > Server > New OGC API Server en plak de URL onder ‘Server URL’. 

Klik op OK.  

 

 

4. De gewenste lagen zijn nu terug te vinden onder ‘Servers’ in de Catalogus van je ArcGIS Pro project. 

Dezelfde werkwijze wordt toegepast om een WFS toe te voegen aan je project.  

 

5. Voeg de gewenste laag toe aan je Map door Rechtermuisklik > Add To Current Map.  
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3.2 OPMAAK AANPASSEN 

De opmaak aanpassen van de OGC Feature laag loopt parallel met het aanpassen van elke andere Feature Class 

laag.  

1. Rechtermuisklik op laag in Contents paneel > Symbology.   

2. Klik op het reeds ingestelde symbool om te kiezen uit opmaak opties uit de ArcGIS gallerij of kies je 

eigen opmaak (Appearance) onder de Properties tab.  

 

3. Ook het gebruik van andere opmaak opties is mogelijk door in plaats van Single Symbol bijvoorbeeld te 

kiezen voor Graduated Colors, waarbij kwantitatieve verschillen op basis van een attribuut worden 

getoond aan de hand van een kleuren schema.  

3.3 FUNCTIES  

Ook de meeste basisfuncties die niets veranderen aan de originele geometrie of data van de OGC API Feature 

zijn mogelijk, denk aan selectie opvragen van features op basis van locatie of attribuut, insersect, contains,  een 

buffer analyse, etc. De volledige lijst van mogelijke functies kan opgevraagd worden via een GET request (vb. 

https://geo.api.vlaanderen.be/Bedrijventerreinen/ogc/features/v1/functions) in een API query tool zoals Postman. 

Hieronder een voorbeeld van de buffer tool op een OGC API Feature:  

1. Kies in het Geoprocessing paneel (Analysis > Tools) voor de Pairwise Buffer en vul de nodige parameters 

in.  

2. Een buffer van de laag wordt gegenereerd waarbij de originele attributen van de OGC API Feature laag 

mee worden genomen in de attributen tabel van de buffer laag.  
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3.4 FEATURE LIMIT AANPASSEN 

Standaard laadt ArcGIS Pro een default maximum aantal van 3000 features in per server request om een 

evenwicht te houden tussen performance en bruikbaarheid van de server laag. Deze limiet kan echter manueel 

worden aangepast. 

1. Vooraleer de limiet verhoogd wordt is het nuttig om na te gaan hoeveel features de laag bevat. 

Rechtermuisklik op de laag in de Contents > Attribute Table. Onderaan kan je het aantal features in de 

lijst terugvinden. Als er ‘0 of 3.000 selected’ staat, word je server request begrensd door de maximum 

limiet. Het kan dan nuttig zijn om je limiet te verhogen.  

2. Rechtermuisklik laag > Properties (of dubbelklik).  

3. Scrol naar beneden tot de Tab ‘OGC Features’ en pas het maximum aantal geretourneerde features 

aan. 

 

4. Druk op Apply en wacht tot het nieuwe aantal features inlaadt. Het kan zijn dat ArcGIS Pro opnieuw 

opgestart moet worden om het nieuwe maximum aantal te registreren.  

Bij lagen die een kleine duizend features bevatten kan dit zonder de performance te sterk te benadelen. Pas wel 

op bij OGC API Features met grote lagen zoals de administratieve percelen laag van het GRB (> 4.8 miljoen 

features). Het inladen van alle features van deze laag kan of heel lang duren (tot meerdere uren) of ArcGIS Pro 

doen vastlopen.  
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3.5 DATA EXPORT 

3.5.1 Laag editeerbaar maken 

1. Rechtermuisklik op laag in Contents > Data > Export Features.  

2. Stel onder Environments > Output Coordinates het gewenste coördinaatsysteem in van je 

geëxporteerde features. Het standaard coördinatensysteem van een OGC API Feature is WGS 84. Voor 

kaarten in België kan het dus nuttig zijn een transformatie uit te voeren naar Lambert 72 of dergelijke.  

    

3. Geef de nieuwe geëxporteerde Feature Class een naam onder Parameters > Output Feature Class en 

druk op OK.   

4. De geëxporteerde laag is nu beschikbaar in je kaart en kan bewerkt worden: feature bewerking, 

attribuut toevoegen, etc. De geëxporteerde laag heeft geen verbinding meer met de OGC API Feature 

en zal dus niet up-to-date blijven volgens updates van Digitaal Vlaanderen.  
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3.5.2 Uploaden naar of gebruiken in ArcGIS Online  

Je kan de data ook uploaden naar je ArcGIS Online portaal of de data toevoegen als een OGC API Feature.  

1. Om de data als geëxporteerde features te gebruiken in ArcGIS Online klik je rechtermuisklik op de laag 

> Sharing > Share As Web Layer. De data wordt op deze manier gepubliceerd in je ArcGIS Online portaal 

waar die wordt gehost als Feature Layer, niet als OGC Feature Layer. 

 

 

 

2. Als je toch ook je ArcGIS Online potaal de data als OGC API Feature wil opvragen, kan je via Content > 

New item > URL de Endpoint URL van de gewenste OGC API Feature toevoegen.  
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3.6 ZELF EEN OGC API FEATURE AANMAKEN  

Als je zelf een feature class hebt dat je wil beschikbaar maken als OGC API Feature, kan dit ook eenvoudig aan 

de hand van ArcGIS Pro en je Online of Enterprise account.  

1. Eens je feature class gereed is, klik je rechtermuisklik in het Contents Paneel > Sharing > Share As Web 

Layer.  
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2. Duid onder de tab General > Reference registered data > Map Image > Feature aan en ga naar de 

Configuration Tab. Duid onder de tab Configuration > Additional Layers > OGC Features aan. Als je niet 

kiest voor ‘Reference registered data’, zal de optie van OGC Features niet beschikbaar zijn.  

  

3. Druk op Analyze om na te gaan of de laag kan worden gepubliceerd en los de errors op indien nodig. 

Mogelijke errors zijn de standaard 00374 en de 00231. Om error 00374 op te lossen dien je via Contents 

> Rechtermuisklik Map > General > Allow assignment of unique numeric Ids for sharing web layers aan 

te vinken. Hiermee sta je de aanwijzing van statische ID's toe aan lagen en op zichzelf staande tabellen. 

De tweede error ‘00231 Layer’s data source must be registered with the server’ geeft aan dat je ArcGIS 

Online of Enterprise account nog geen referentie heeft naar waar je de data hebt opgeslagen. Hier zijn 

er 2 opties: 

 - Lokale opslag: Voeg je path naar je lokale opslag toe als data store ➔ Rechtermuisklik error 

 > Register Data Source With Server. 

 - Voeg een database connection toe naar een server ➔ Catalog > Databases > 

 Rechtermuisklik > New Database Connection. Laad vervolgens je feature class op in de server 

 of gebruik een reeds bestaande feature class uit de server.  
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4. Klik op Publish om je laag te publiceren. Deze zal nu terug te vinden zijn als Feature Layer, Map Image 

Layer en als OGC Feature Layer in je ArcGIS Enterprise of Online portaal.  

 

5. Je kan ook de landingspagina van je net aangemaakte OGC API Feature raadplegen door te klikken op 

de OGC Feature Layer in je Content, te scrollen naar de onderkant van je pagina en rechtsonder je 

URL te kopiëren naar een nieuw browser tablad. 
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4 VERSCHIL MET WFS  

4.1 COÖRDINAATSYSTEEM   

Het belangrijkste verschil met de voorheen gebruikte WFS is het coördinatensysteem. Voor WFS wordt bij 

Digitaal Vlaanderen standaard Lambert 72 (EPSG:31370) gebruikt, terwijl de OGC API Feature standaard default 

WGS 84 gebruikt. De structuur van de OGC API Feature laat echter wel toe om andere mogelijke 

coördinaatsystemen op te slaan in de data, waardoor deze wel als filter gebruikt kunnen worden om bepaalde 

features op te vragen in een ander coördinaatsysteem. Hieronder zie je een voorbeeld van de mogelijke 

coördinaatsystemen die gebruikt kunnen worden voor de Bedrijventerreinen OGC API Feature, opgeslagen in de 

mogelijke parameters van een van de collecties (lagen). Deze data is bevraagd door een GET request in Postman;  

https://geo.api.vlaanderen.be/Bedrijventerreinen/ogc/features/v1/collections/Bedrter.  

    "crs": [ 

        "http://www.opengis.net/def/crs/OGC/1.3/CRS84", 

        "http://www.opengis.net/def/crs/EPSG/0/31370", 

        "http://www.opengis.net/def/crs/EPSG/0/4326", 

        "http://www.opengis.net/def/crs/EPSG/0/4258", 

        "http://www.opengis.net/def/crs/EPSG/0/3812", 

        "http://www.opengis.net/def/crs/EPSG/0/3043", 

        "http://www.opengis.net/def/crs/EPSG/0/32631", 

        "http://www.opengis.net/def/crs/EPSG/0/25831", 

        "http://www.opengis.net/def/crs/EPSG/0/3857", 

        "http://www.opengis.net/def/crs/EPSG/0/102100", 

        "http://www.opengis.net/def/crs/EPSG/0/3035" 

    ], 

    "storageCrs": "http://www.opengis.net/def/crs/EPSG/0/31370" 

} 

 

Naast alle filter opties, zie je onder “storageCrs” ook dat de data initieel opgeslagen is onder de Lambert 72 

projectie (EPSG:31370). De OGC API Feature standaarden schrijven echter voor dat de verspreiding van de data 

verder default moet gebeuren onder 1 algemeen coördinatensysteem, namelijk WGS84.  
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